Garden and General update

Didn’t mean to go radio silent for so long, its been a busy couple weeks!  Plus I kept forgetting to get garden photos, and so kept delaying posting till I could get photos, and then forgetting to get photos…..

Pulled this giant carrot out of the garden:

The variety name is Oxheart, they can reach over 1lb in weight in about 90 days.  I didn’t weigh this one, but it sure was big!  Good carrot flavor too, I was worried it would be tough, but it wasn’t.  There’s still another giant one out there to be pulled.

My second try at picking a Snow Leopard melon I left it on the vine to long, and it split (from the blossom end) in a bit split taking over half the melon.  However the undamaged half was EXTREMELY tasty.  My 3rd attempt was just about perfect I think, it was showing signs of being about to split, but hadn’t quite, and was just about as nice tasting as the 2nd.

Tomatoes are just about done, the vines are dying back.

Today’s weather we’re predicted to hit 80 out there, but then its going to drop back to the unseasonably cool temps of upper 60’s to low 70’s, with nights in the 50’s or cooler.  Tomorrow I’m probably going to drop frost covers on the melons and peppers to see if I can convince them to finish ripening.

This past week was State Fair week, normal State Fair weather is hot, 90’s, and sometimes nasty raining.  Instead we had cool and sunny.  I understand that the Fair was packed both weekends and most evenings.  We went on this past Friday during mid-day and it wasn’t to bad crowds wise.

No Honey Dew melons for me this year it looks like.  I have a picture from several weeks ago that appeared to be a fertilized female flower, but the baby fruit died off instead, and I haven’t seen any others even close since.

We got a couple cantaloupe.  One watermelon.  There’s a BUNCH of Green Nutmeg melons out there, but none of them appear to be ripe yet.  They’re a close relative of the cantaloupe and so should fall off the vine when they’re ripe, but none of them have done so yet.

I’ve been having a HORRID time with bug damage on my hot peppers this year.  Damage identical to the damage I was seeing on the paprika peppers last year.  Minimal leaf damage, but fruit rotting on the plant after huge holes chewed into the peppers.  I found this bug on a severely damaged Hungarian Hot Wax pepper and posted the photo on a hot pepper group on FB:

 

This fellow is likely one of the variety of Leaf Footed Bugs, a relative of the Stink Bug.  And some varieties do indeed do this sort of damage.  I treated all the peppers with pyrethrum just over a week ago, very carefully staying away from any remaining blossoms, and will likely do so again this week.  And I’ll have to remember to do so in the spring after planting too.

Just about 2 weeks ago I went into my doctor with what seemed to be early UTI symptoms.  A constant feeling like I needed to pee mostly.  Thankfully it wasn’t actually painfull (I’ve had some really painfull UTIs) but I wanted to get it taken care of before it got that bad.  The in house urine test showed a small amount of blood, bacteria, and a 3rd thing I forget the name of, all indicative of a UTI.  The doctor gave me an antibiotic, and the urine sample was sent off to the lab to be sure of the bacteria type, and to make sure they weren’t missing anything.  Turns out that the bacteria type was only kinda sorta responsive to the antibiotic I was given, however since my symptoms appeared to be fading the decision was made to finish the course of antibiotics I was on, and then in another week do another urine test.

I finished the antibiotic last Tuesday.  Wednesday evening my UTI symptoms came back.  Called the doctor Thursday morning, and left a message, they called me back Friday morning.  By which time I was outright painful, including kidney pain.  They had me come in and go directly to the inhouse lab to leave a urine sample.  The inhouse test showed no blood, no bacteria, and none of whatever the 3rd thing was that I can’t remember.  But slightly high bilirubin.  The big lab test showed slightly elevated urethral flora.  THAT test result came in Saturday evening, I can see it on the patient portal.  Hoping to get a call from the doctor today with an idea of whats going on.  I’m still experiencing some kidney pain, and a constant need to pee, though its no longer an outright painful need to pee.  If I don’t get a call today I’ll have to call them tomorrow.

6 Comments

  1. Comment by threecollie:

    Hope you feel better soon.

    • Comment by Ruth:

      The anti-inflammatory I take daily definitely helps with the pain, but I’m not thrilled with the constant kidney pain, no matter how reduced.

      No phone call today, so tomorrow I call them!

  2. Comment by Rain Frances:

    Hi Ruth, geez I hope you get this all figured out. I’ve had horrid UTI’s as well, and had to wait 18 hours one time in the waiting room of the emergency for a prescription. I take daily cranberry pills now and haven’t had an issue in years. I’m sorry you’re going through that!

    That carrot is amazing! 🙂

    • Comment by Ruth:

      Thankfully I don’t really get them often. Every couple years or so. Enough that I know the symptoms, not enough to actually worry anyone. But this extended problem is a first for me. Not thrilled…..

  3. Comment by bogie:

    Oh that is horrid. I’ve only had a couple in my life (KOW) so feel really lucky that I don’t get them! Hope you got ahold of them and they got you on the correct treatment asap.

    That carrot is just too much! I thought for sure it would be tough so glad it wasn’t – and tasty too so that’s definitely a keeper for your future gardening.

    • Comment by Ruth:

      Doctor says the lab results mean no UTI. When I explained that I’m still having symptoms, the response was that we’re going to wait another week and do another urine test. Drink lots of water, don’t drink alcohol or smoke, yaddayahha. Not amused. Not my usual doctor either, who I’m scheduled to see next week for something unrelated, I might just re-purpose the visit…..